漏洞详情: CVE-2024-37899

漏洞标题
Disabling a user account changes its author, allowing RCE from user account in XWiki
来源:NVD
XWiki Platform 安全漏洞
来源:CNNVD
漏洞描述
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account. To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add `{{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}`. As an admin, go to the user profile and click the "Disable this account" button. Then, reload the page. If the logs show `attacker - Hello from Groovy!` then the instance is vulnerable. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Users are advised to upgrade. There are no known workarounds for this vulnerability. ### Workarounds We're not aware of any workaround except upgrading. ### References * https://jira.xwiki.org/browse/XWIKI-21611 * https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a
来源:NVD
XWiki Platform是XWiki基金会的一套用于创建Web协作应用程序的Wiki平台。 XWiki Platform 14.10.21、15.5.5、15.10.6 和 16.0.0之前版本存在安全漏洞,该漏洞源于禁用用户帐户会更改其作者,从而允许攻击者通过用户帐户执行远程代码。
来源:CNNVD
NVD 暂无描述信息
来源:神龙机器人
漏洞评分(CVSS)
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
来源:NVD
漏洞类别
对生成代码的控制不恰当(代码注入)
来源:NVD
其他
来源:CNNVD
相关链接