目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2026-42150— wlc 跨站脚本漏洞

一分钟漏洞结论

影响对象
WeblateOrg wlc
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

wlc是Weblate开源的一个命令行客户端。 wlc 2.0.0之前版本存在跨站脚本漏洞,该漏洞源于HTML输出格式未转义API响应数据,可能导致跨站脚本攻击。

CVSS 5.1 · Medium EPSS 0.17% · P7

影响版本矩阵 1

厂商产品 版本范围状态
WeblateOrg wlc < 2.0.0 affected
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2026-42150 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
wlc: print_html outputs API data without HTML escaping, enabling stored XSS
来源: CVE Program / CVE List V5
Vulnerability Description
wlc is a Weblate command-line client using Weblate's REST API. Prior to version 2.0.0, the HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser. This issue has been patched in version 2.0.0.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:L
来源: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
来源: CVE Program / CVE List V5
Vulnerability Title
wlc 跨站脚本漏洞
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Description
wlc是Weblate开源的一个命令行客户端。 wlc 2.0.0之前版本存在跨站脚本漏洞,该漏洞源于HTML输出格式未转义API响应数据,可能导致跨站脚本攻击。
来源: 中国国家信息安全漏洞库 CNNVD
CVSS Information
N/A
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Type
N/A
来源: 中国国家信息安全漏洞库 CNNVD

受影响产品

厂商 产品 影响版本 CPE 订阅
WeblateOrg wlc < 2.0.0 -

二、漏洞 CVE-2026-42150 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2026-42150 的情报信息

请登录查看更多情报信息。

CVE-2026-42150 补丁与修复 (2)

CVE-2026-42150 厂商安全公告 (1)

CVE-2026-42150 厂商页面 (1)

IV. Related Vulnerabilities