目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2021-4231— Angular 跨站脚本漏洞

一分钟漏洞结论

影响对象
unspecified Angular
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

Angular是一个开发平台。用于使用 Typescript / JavaScript 和其他语言构建移动和桌面 Web 应用程序。 Angular 11.0.4、11.1.0-next.2版本存在安全漏洞,该漏洞源于HTML 没有指定任何方法来转义评论中的文本,攻击者利用该漏洞能够将任意html和脚本代码注入网站。

CVSS 3.5 · Low EPSS 1.18% · P68

可能的 ATT&CK 技术 1 AI

T1189 · Drive-by Compromise
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2021-4231 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
Angular Comment cross site scripting
来源: CVE Program / CVE List V5
Vulnerability Description
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
来源: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
来源: CVE Program / CVE List V5
Vulnerability Title
Angular 跨站脚本漏洞
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Description
Angular是一个开发平台。用于使用 Typescript / JavaScript 和其他语言构建移动和桌面 Web 应用程序。 Angular 11.0.4、11.1.0-next.2版本存在安全漏洞,该漏洞源于HTML 没有指定任何方法来转义评论中的文本,攻击者利用该漏洞能够将任意html和脚本代码注入网站。
来源: 中国国家信息安全漏洞库 CNNVD
CVSS Information
N/A
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Type
N/A
来源: 中国国家信息安全漏洞库 CNNVD

受影响产品

厂商 产品 影响版本 CPE 订阅
unspecified Angular 11.0.0 -

二、漏洞 CVE-2021-4231 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2021-4231 的情报信息

请登录查看更多情报信息。

CVE-2021-4231 补丁与修复 (1)

CVE-2021-4231 厂商安全公告 (2)

CVE-2021-4231 其他参考 (1)

IV. Related Vulnerabilities