Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2023-25565— GSS-NTLMSSP vulnerable to incorrect free when decoding target information

Quick assessment

Affected
gssapi gss-ntlmssp
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

GSS-NTLMSSP是gssapi开源的一个实现 NTLM 身份验证的 GSSAPI 库的 mechglue 插件。 GSS-NTLMSSP 1.2.0之前版本存在安全漏洞,该漏洞源于解码目标信息时错误的释放会触发拒绝服务,攻击者可以通过“gss_accept_sec_context”主入口点触发该漏洞。

CVSS 7.5 · High EPSS 1.10% · P66

Possible ATT&CK Techniques 1 AI

T1499 · Endpoint Denial of Service
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2023-25565

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
GSS-NTLMSSP vulnerable to incorrect free when decoding target information
Source: CVE Program / CVE List V5
Vulnerability Description
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Source: CVE Program / CVE List V5
Vulnerability Type
释放并不在堆上的内存
Source: CVE Program / CVE List V5
Vulnerability Title
GSS-NTLMSSP 安全漏洞
Source: CNNVD (China National Vulnerability Database)
Vulnerability Description
GSS-NTLMSSP是gssapi开源的一个实现 NTLM 身份验证的 GSSAPI 库的 mechglue 插件。 GSS-NTLMSSP 1.2.0之前版本存在安全漏洞,该漏洞源于解码目标信息时错误的释放会触发拒绝服务,攻击者可以通过“gss_accept_sec_context”主入口点触发该漏洞。
Source: CNNVD (China National Vulnerability Database)
CVSS Information
N/A
Source: CNNVD (China National Vulnerability Database)
Vulnerability Type
N/A
Source: CNNVD (China National Vulnerability Database)

Affected Products

Vendor Product Affected Versions CPE Subscribe
gssapi gss-ntlmssp < 1.2.0 -

II. Public POCs for CVE-2023-25565

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2023-25565

请登录查看更多情报信息。

Patches & Fixes for CVE-2023-25565 (1)

Vendor Advisories for CVE-2023-25565 (1)

Other References for CVE-2023-25565 (1)

Same Patch Batch · gssapi · 2023-02-14 · 5 CVEs total

CVE-2023-25566 7.5 HIGH GSS-NTLMSSP vulnerable to memory leak when parsing usernames
CVE-2023-25567 7.5 HIGH GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information
CVE-2023-25564 6.5 MEDIUM GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings
CVE-2023-25563 5.9 MEDIUM GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields

IV. Related Vulnerabilities