Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2023-25567— GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information

Quick assessment

Affected
gssapi gss-ntlmssp
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

GSS-NTLMSSP是gssapi开源的一个实现 NTLM 身份验证的 GSSAPI 库的 mechglue 插件。 GSS-NTLMSSP 1.2.0之前版本存在缓冲区错误漏洞,该漏洞源于未针对可能触发越界读取的两个元素av_pair 的长度进行正确检查 ,解码目标信息时可能导致越界读取,攻击者可以通过“gss_accept_sec_context”主入口点触发该漏洞。

CVSS 7.5 · High EPSS 1.10% · P66

Possible ATT&CK Techniques 1 AI

T1190 · Exploit Public-Facing Application
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2023-25567

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information
Source: CVE Program / CVE List V5
Vulnerability Description
GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Source: CVE Program / CVE List V5
Vulnerability Type
跨界内存读
Source: CVE Program / CVE List V5
Vulnerability Title
GSS-NTLMSSP 缓冲区错误漏洞
Source: CNNVD (China National Vulnerability Database)
Vulnerability Description
GSS-NTLMSSP是gssapi开源的一个实现 NTLM 身份验证的 GSSAPI 库的 mechglue 插件。 GSS-NTLMSSP 1.2.0之前版本存在缓冲区错误漏洞,该漏洞源于未针对可能触发越界读取的两个元素av_pair 的长度进行正确检查 ,解码目标信息时可能导致越界读取,攻击者可以通过“gss_accept_sec_context”主入口点触发该漏洞。
Source: CNNVD (China National Vulnerability Database)
CVSS Information
N/A
Source: CNNVD (China National Vulnerability Database)
Vulnerability Type
N/A
Source: CNNVD (China National Vulnerability Database)

Affected Products

Vendor Product Affected Versions CPE Subscribe
gssapi gss-ntlmssp < 1.2.0 -

II. Public POCs for CVE-2023-25567

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2023-25567

请登录查看更多情报信息。

Vendor Advisories for CVE-2023-25567 (1)

Other References for CVE-2023-25567 (1)

Same Patch Batch · gssapi · 2023-02-14 · 5 CVEs total

CVE-2023-25565 7.5 HIGH GSS-NTLMSSP vulnerable to incorrect free when decoding target information
CVE-2023-25566 7.5 HIGH GSS-NTLMSSP vulnerable to memory leak when parsing usernames
CVE-2023-25564 6.5 MEDIUM GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings
CVE-2023-25563 5.9 MEDIUM GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields

IV. Related Vulnerabilities