目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2024-3931— Totara LMS 跨站脚本漏洞

一分钟漏洞结论

影响对象
Totara LMS
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

Totara LMS是Totara公司的一个学习管理系统。 Totara LMS 18.0.1 Build 20231128.01版本存在跨站脚本漏洞,该漏洞源于组件 Profile Handler 中的 admin/roles/check.php 包含一些未知函数,通过参数 ID 号导致跨站脚本。

CVSS 3.5 · Low EPSS 0.43% · P38

可能的 ATT&CK 技术 1 AI

T1189 · Drive-by Compromise
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2024-3931 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
Totara LMS User Selector check.php cross site scripting
来源: CVE Program / CVE List V5
Vulnerability Description
A vulnerability was found in Totara LMS up to 18.7. It has been rated as problematic. Affected by this issue is some unknown functionality of the file admin/roles/check.php of the component User Selector. The manipulation of the argument ID Number leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
来源: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
来源: CVE Program / CVE List V5
Vulnerability Title
Totara LMS 跨站脚本漏洞
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Description
Totara LMS是Totara公司的一个学习管理系统。 Totara LMS 18.0.1 Build 20231128.01版本存在跨站脚本漏洞,该漏洞源于组件 Profile Handler 中的 admin/roles/check.php 包含一些未知函数,通过参数 ID 号导致跨站脚本。
来源: 中国国家信息安全漏洞库 CNNVD
CVSS Information
N/A
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Type
N/A
来源: 中国国家信息安全漏洞库 CNNVD

受影响产品

厂商 产品 影响版本 CPE 订阅
Totara LMS 13.0 -

二、漏洞 CVE-2024-3931 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2024-3931 的情报信息

请登录查看更多情报信息。

CVE-2024-3931 厂商安全公告 (2)

CVE-2024-3931 厂商页面 (1)

IV. Related Vulnerabilities