Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2025-27371

Quick assessment

Affected
IETF RFC 7523
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

OpenID IETF OAuth是OpenID基金会的一个授权框架。 OpenID IETF OAuth 2.0版本存在安全漏洞,该漏洞源于受众值模糊。

CVSS 6.9 · Medium EPSS 0.35% · P26
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2025-27371

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
N/A
Source: CVE Program / CVE List V5
Vulnerability Description
In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience values of JWTs sent to authorization servers. The affected RFCs may include RFC 7523, and also RFC 7521, RFC 7522, RFC 9101 (JAR), and RFC 9126 (PAR).
Source: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
Source: CVE Program / CVE List V5
Vulnerability Type
使用基本弱点进行的认证绕过
Source: CVE Program / CVE List V5
Vulnerability Title
OpenID IETF OAuth 安全漏洞
Source: CNNVD (China National Vulnerability Database)
Vulnerability Description
OpenID IETF OAuth是OpenID基金会的一个授权框架。 OpenID IETF OAuth 2.0版本存在安全漏洞,该漏洞源于受众值模糊。
Source: CNNVD (China National Vulnerability Database)
CVSS Information
N/A
Source: CNNVD (China National Vulnerability Database)
Vulnerability Type
N/A
Source: CNNVD (China National Vulnerability Database)

Affected Products

Vendor Product Affected Versions CPE Subscribe
IETF RFC 7523 7523 -

II. Public POCs for CVE-2025-27371

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2025-27371

请登录查看更多情报信息。

Vendor Advisories for CVE-2025-27371 (1)

Proof of Concept for CVE-2025-27371 (1)

Security Blog Posts for CVE-2025-27371 (1)

News Coverage for CVE-2025-27371 (1)

IV. Related Vulnerabilities

V. Comments for CVE-2025-27371

No comments yet


Leave a comment