目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2026-119924— Babelfish PostgreSQL TDS 越界读取漏洞

一分钟漏洞结论

影响对象
AWS babelfish-for-postgresql
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

Babelfish for PostgreSQL 扩展的 TDS RPC 过程名解析器中存在越界读取漏洞,影响版本 1.0–1.5、2.1–2.15、3.1–3.12、4.0–4.8 和 5.1–5.4,同时也影响集成 Babelfish 的 Amazon Aurora PostgreSQL。该漏洞允许经过身份验证的远程攻击者通过向 TDS 端口(默认 1433)发送畸形的 TDS RPC 请求,读取相邻进程内存或导致拒绝服务。 为修复此问题,建议用户将 Babelfish for PostgreSQL 扩展升级至

CVSS 8.1 · High
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2026-119924 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
Out-of-Bounds Read in Babelfish for PostgreSQL TDS RPC Procedure-Name Parser
来源: CVE Program / CVE List V5
Vulnerability Description
An out-of-bounds read in the TDS RPC procedure-name parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote authenticated users to read adjacent process memory or cause a denial of service via a malformed TDS RPC request to the TDS port (default 1433). To remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. As a workaround, restrict network access to the TDS port (default 1433). Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their cluster to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.1), 14.23.1 (2.17.0), 15.10.8 (3.8.4), 15.12.8 (3.9.4), 15.13.6 (3.10.3), 15.14.5 (3.11.2), 15.15.5 (3.12.2), 15.17.3 (3.13.1), 15.18.1 (3.14.0), 16.8.8 (4.5.5), 16.9.6 (4.6.3), 16.10.5 (4.7.2), 16.11.5 (4.8.2), 16.13.3 (4.9.1), 16.14.1 (4.10.0), 17.4.8 (5.1.4), 17.5.6 (5.2.3), 17.6.5 (5.3.2), 17.7.5 (5.4.2), 17.9.3 (5.5.1), 17.10.1 (5.6.0), 18.3.4 (6.0.2), 18.4.1 (6.1.0) or later, and apply any pending maintenance to ensure they are on the latest patch.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
来源: CVE Program / CVE List V5
Vulnerability Type
跨界内存读
来源: CVE Program / CVE List V5

受影响产品

厂商 产品 影响版本 CPE 订阅
AWS babelfish-for-postgresql 1.0 ~ 1.5 -
Amazon Amazon Aurora PostgreSQL with Babelfish 1.0.0 ~ 1.5.5 -

二、漏洞 CVE-2026-119924 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2026-119924 的情报信息

请登录查看更多情报信息。

CVE-2026-119924 其他参考 (4)

同批安全公告 · AWS · 2026-11-06 · 共 3 条

CVE-2026-122193 9.9 CRITICAL Trusted REX 示例文档 OS 命令注入漏洞
CVE-2026-119923 9.8 CRITICAL Babelfish for PostgreSQL TDS 堆溢出漏洞

IV. Related Vulnerabilities