目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2026-120597— Welcart 插件 paymentESCOTT.main.class.php 跨站脚本漏洞

一分钟漏洞结论

影响对象
Welcart e-Commerce Plugin
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

在 WordPress 平台上的 Welcart 电子商务插件(版本 2.12.6 及以下)中发现了一个安全漏洞。该漏洞影响文件 中的 函数。攻击者可通过操纵 参数引发跨站脚本攻击(XSS)。该攻击可远程发起,且利用代码已在公开渠道发布,存在被实际利用的风险。 升级至版本 2.12.7 可缓解此问题,建议立即升级受影响的组件。修复方案中,相关值在输出前已通过 函数进行转义处理。厂商已在早期收到报告,并以高度专业的态度迅速响应,及时发布了含修复补丁的产品版本。

CVSS 4.3 · Medium
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2026-120597 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting
来源: CVE Program / CVE List V5
Vulnerability Description
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
来源: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
来源: CVE Program / CVE List V5

受影响产品

厂商 产品 影响版本 CPE 订阅
Welcart e-Commerce Plugin 2.12.0 cpe:2.3:a:welcart:e-commerce_plugin:*:*:*:*:*:*:*:*

二、漏洞 CVE-2026-120597 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2026-120597 的情报信息

请登录查看更多情报信息。

CVE-2026-120597 厂商页面 (1)

CVE-2026-120597 其他参考 (5)

IV. Related Vulnerabilities