Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2026-120597— Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting

Quick assessment

Affected
Welcart e-Commerce Plugin
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

在 WordPress 平台上的 Welcart 电子商务插件(版本 2.12.6 及以下)中发现了一个安全漏洞。该漏洞影响文件 中的 函数。攻击者可通过操纵 参数引发跨站脚本攻击(XSS)。该攻击可远程发起,且利用代码已在公开渠道发布,存在被实际利用的风险。 升级至版本 2.12.7 可缓解此问题,建议立即升级受影响的组件。修复方案中,相关值在输出前已通过 函数进行转义处理。厂商已在早期收到报告,并以高度专业的态度迅速响应,及时发布了含修复补丁的产品版本。

CVSS 4.3 · Medium

Possible ATT&CK Techniques 1 AI

T1190 · Exploit Public-Facing Application
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2026-120597

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting
Source: CVE Program / CVE List V5
Vulnerability Description
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Source: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
Source: CVE Program / CVE List V5

Affected Products

Vendor Product Affected Versions CPE Subscribe
Welcart e-Commerce Plugin 2.12.0 cpe:2.3:a:welcart:e-commerce_plugin:*:*:*:*:*:*:*:*

II. Public POCs for CVE-2026-120597

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2026-120597

请登录查看更多情报信息。

Vendor Pages for CVE-2026-120597 (1)

Other References for CVE-2026-120597 (5)

IV. Related Vulnerabilities