目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2026-121652— AWS Amplify maplibre-gl-js-amplify 存储型跨站脚本漏洞

一分钟漏洞结论

影响对象
AWS maplibre-gl-js-amplify
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

在 AWS Amplify 的 组件 4.0.3 之前版本中存在跨站脚本(XSS)漏洞。该漏洞可能允许经过身份验证的远程攻击者,通过以下方式注入任意 Web 脚本或 HTML 代码: 1. 属性 2. 属性 3. 属性 上述属性均出现在由 渲染的 GeoJSON 特征数据中;或者 4. 在 中渲染的 值。 为修复此问题,用户应升级至 4.0.3 或更高版本。

CVSS 5.4 · Medium EPSS 0.26% · P18

影响版本矩阵 1

厂商产品 版本范围状态
AWS maplibre-gl-js-amplify < 4.0.3 affected
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2026-121652 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering
来源: CVE Program / CVE List V5
Vulnerability Description
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
来源: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
来源: CVE Program / CVE List V5

受影响产品

厂商 产品 影响版本 CPE 订阅
AWS maplibre-gl-js-amplify 0 ~ 4.0.3 -

二、漏洞 CVE-2026-121652 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2026-121652 的情报信息

请登录查看更多情报信息。

CVE-2026-121652 其他参考 (3)

同批安全公告 · AWS · 2026-11-03 · 共 3 条

CVE-2026-119922 8.8 HIGH Babelfish PostgreSQL 权限提升漏洞
CVE-2026-119084 8.1 HIGH Amazon Redshift JDBC 驱动远程代码执行漏洞

IV. Related Vulnerabilities