Vulnerability Information
Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.
Vulnerability Title
fast-uri vulnerable to host confusion via literal backslash authority delimiter
Vulnerability Description
Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts.
Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3.
Workarounds: none.
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Vulnerability Type
解释冲突
Vulnerability Title
fast-uri 处理逻辑错误漏洞
Vulnerability Description
fast-uri fast-uri是fast-uri的Web中间件。 fast-uri存在处理逻辑错误漏洞,该漏洞源于未将反斜杠字符(U+005C)视为权威分隔符,导致URL解析器与Node原生WHATWG URL解析器提取不同主机,可能导致应用被导向非预期目标,包括云元数据端点、回环地址或内部主机。以下版本受到影响:2.3.1至2.4.2版本、3.0.0至3.1.3版本和4.0.0至4.1.0版本。
CVSS Information
N/A
Vulnerability Type
N/A