漏洞信息
尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。
Vulnerability Title
fast-uri vulnerable to host confusion via backslash authority introducer
Vulnerability Description
fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Vulnerability Type
解释冲突
Vulnerability Title
Fastify fast-uri 处理逻辑错误漏洞
Vulnerability Description
fast-uri fast-uri是fast-uri的Web中间件。 Fastify fast-uri 4.1.2之前版本、3.1.5之前版本和2.4.4之前版本存在处理逻辑错误漏洞,该漏洞源于fast-uri与Node的URL解析器对反斜杠处理不一致,导致主机解析差异,可能被利用绕过基于主机的安全策略(如允许列表、SSRF过滤、重定向验证),将请求导向意外主机。
CVSS Information
N/A
Vulnerability Type
N/A