Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2026-34060— Ruby LSP has arbitrary code execution through branch setting

Quick assessment

Affected
Shopify ruby-lsp
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

Ruby LSP是Shopify开源的一个Ruby语言服务器,提供代码补全和调试功能。 Ruby LSP 0.10.2之前版本和0.26.9之前版本存在代码注入漏洞,该漏洞源于rubyLsp.branch VS Code工作区设置未经清理即插入生成的Gemfile,可能导致执行任意Ruby代码。

AI Predicted 7.8 Difficulty: Easy EPSS 0.50% · P43

Possible ATT&CK Techniques 1 AI

T1190 · Exploit Public-Facing Application
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2026-34060

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
Ruby LSP has arbitrary code execution through branch setting
Source: CVE Program / CVE List V5
Vulnerability Description
Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Source: CVE Program / CVE List V5
Vulnerability Type
对生成代码的控制不恰当(代码注入)
Source: CVE Program / CVE List V5
Vulnerability Title
Ruby LSP 代码注入漏洞
Source: CNNVD (China National Vulnerability Database)
Vulnerability Description
Ruby LSP是Shopify开源的一个Ruby语言服务器,提供代码补全和调试功能。 Ruby LSP 0.10.2之前版本和0.26.9之前版本存在代码注入漏洞,该漏洞源于rubyLsp.branch VS Code工作区设置未经清理即插入生成的Gemfile,可能导致执行任意Ruby代码。
Source: CNNVD (China National Vulnerability Database)
CVSS Information
N/A
Source: CNNVD (China National Vulnerability Database)
Vulnerability Type
N/A
Source: CNNVD (China National Vulnerability Database)

Affected Products

Vendor Product Affected Versions CPE Subscribe
Shopify ruby-lsp < 0.26.9 -
Shopify Shopify.ruby-lsp < 0.10.2 -

II. Public POCs for CVE-2026-34060

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2026-34060

请登录查看更多情报信息。

IV. Related Vulnerabilities