目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2026-48093— David Artiss Code Embed 跨站脚本漏洞

一分钟漏洞结论

影响对象
dartiss code-embed
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

David Artiss Code Embed是David Artiss个人开发者的一个代码嵌入工具。 David Artiss Code Embed 2.6.1之前版本存在跨站脚本漏洞,该漏洞源于文章内容中的外部URL嵌入功能在渲染内容时扫描URL嵌入令牌并获取远程URL,将远程响应内容直接插入页面,且未进行输出清理和转义,也未进行unfiltered_html能力检查,导致容易受到存储型跨站脚本攻击,可能允许贡献者攻击者提交包含URL令牌的待审文章,当管理员或编辑预览或审核文章时执行攻击者控制的Jav

CVSS 6.5 · Medium EPSS 0.29% · P21

影响版本矩阵 1

厂商产品 版本范围状态
dartiss code-embed < 2.6.1 affected
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2026-48093 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
Code Embed - Contributor Stored Cross-Site Scripting via Remote URL Embed
来源: CVE Program / CVE List V5
Vulnerability Description
The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
来源: CVE Program / CVE List V5
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
来源: CVE Program / CVE List V5
Vulnerability Title
David Artiss Code Embed 跨站脚本漏洞
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Description
David Artiss Code Embed是David Artiss个人开发者的一个代码嵌入工具。 David Artiss Code Embed 2.6.1之前版本存在跨站脚本漏洞,该漏洞源于文章内容中的外部URL嵌入功能在渲染内容时扫描URL嵌入令牌并获取远程URL,将远程响应内容直接插入页面,且未进行输出清理和转义,也未进行unfiltered_html能力检查,导致容易受到存储型跨站脚本攻击,可能允许贡献者攻击者提交包含URL令牌的待审文章,当管理员或编辑预览或审核文章时执行攻击者控制的Jav
来源: 中国国家信息安全漏洞库 CNNVD
CVSS Information
N/A
来源: 中国国家信息安全漏洞库 CNNVD
Vulnerability Type
N/A
来源: 中国国家信息安全漏洞库 CNNVD

受影响产品

厂商 产品 影响版本 CPE 订阅
dartiss code-embed < 2.6.1 -

二、漏洞 CVE-2026-48093 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2026-48093 的情报信息

请登录查看更多情报信息。

CVE-2026-48093 补丁与修复 (2)

CVE-2026-48093 厂商安全公告 (1)

IV. Related Vulnerabilities