Vulnerability Information
Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.
Vulnerability Title
Code Embed - Contributor Stored Cross-Site Scripting via Remote URL Embed
Vulnerability Description
The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Vulnerability Type
在Web页面生成时对输入的转义处理不恰当(跨站脚本)
Vulnerability Title
David Artiss Code Embed 跨站脚本漏洞
Vulnerability Description
David Artiss Code Embed是David Artiss个人开发者的一个代码嵌入工具。 David Artiss Code Embed 2.6.1之前版本存在跨站脚本漏洞,该漏洞源于文章内容中的外部URL嵌入功能在渲染内容时扫描URL嵌入令牌并获取远程URL,将远程响应内容直接插入页面,且未进行输出清理和转义,也未进行unfiltered_html能力检查,导致容易受到存储型跨站脚本攻击,可能允许贡献者攻击者提交包含URL令牌的待审文章,当管理员或编辑预览或审核文章时执行攻击者控制的Jav
CVSS Information
N/A
Vulnerability Type
N/A