Vulnerability Information
Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.
Vulnerability Title
Apache Artemis, Apache ActiveMQ Artemis: Message selector wildcard handling could lead to denial of service
Vulnerability Description
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
CVSS Information
N/A
Vulnerability Type
CWE-1333
Vulnerability Title
Apache Artemis 资源管理错误漏洞
Vulnerability Description
Apache Artemis是美国Apache基金会开源的一款支持多种消息协议的高性能消息代理软件。 Apache Artemis 2.50.0版本至2.56.0版本和Apache ActiveMQ Artemis 1.0.0版本至2.44.0版本存在资源管理错误漏洞,该漏洞源于经过身份验证的客户端可附加带有特制通配符用法的选择器消费者,导致消息传递期间过度评估,占用共享代理线程,可能造成拒绝服务。
CVSS Information
N/A
Vulnerability Type
N/A