Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2026-84428— fastify vulnerable to header validation bypass via incomplete schema case normalization

Quick assessment

Affected
fastify fastify
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

Fastify是Fastify团队开源的一个高性能的Node.js Web框架。 Fastify 5.12.2之前版本存在输入验证错误漏洞,该漏洞源于HTTP头名称大小写转换不完整,可能导致未认证的远程客户端绕过条件检查。

CVSS 7.5 · High EPSS 0.52% · P44

Possible ATT&CK Techniques 1 AI

T1190 · Exploit Public-Facing Application

Affected Version Matrix 2

VendorProduct Version RangeStatus
fastify fastify < 5.12.2 affected
5.12.2 unaffected
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2026-84428

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
fastify vulnerable to header validation bypass via incomplete schema case normalization
Source: CVE Program / CVE List V5
Vulnerability Description
fastify versions before 5.12.2 implement the case-insensitive nature of HTTP header names by lowercasing names in a route's header schema before compiling it, but the transformation is incomplete: it lowercases the properties keys and the root-level required array, and does not lowercase the trigger and dependent names inside the JSON Schema Draft 7 dependencies keyword. Because Node stores request header names in lowercase, a canonical-case dependency such as requiring an authentication header whenever a privileged-mode header is present never matches, and the presence assertion is silently skipped. An unauthenticated remote client can therefore send the header that activates a privileged branch while omitting the header the dependency was meant to require, bypassing the conditional check. Users should upgrade to fastify 5.12.2 or later.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Source: CVE Program / CVE List V5
Vulnerability Type
大小写敏感处理不恰当
Source: CVE Program / CVE List V5
Vulnerability Title
Fastify 输入验证错误漏洞
Source: CNNVD (China National Vulnerability Database)
Vulnerability Description
Fastify是Fastify团队开源的一个高性能的Node.js Web框架。 Fastify 5.12.2之前版本存在输入验证错误漏洞,该漏洞源于HTTP头名称大小写转换不完整,可能导致未认证的远程客户端绕过条件检查。
Source: CNNVD (China National Vulnerability Database)
CVSS Information
N/A
Source: CNNVD (China National Vulnerability Database)
Vulnerability Type
N/A
Source: CNNVD (China National Vulnerability Database)

Affected Products

Vendor Product Affected Versions CPE Subscribe
fastify fastify 0 ~ 5.12.2 -

II. Public POCs for CVE-2026-84428

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2026-84428

请登录查看更多情报信息。

Vendor Advisories for CVE-2026-84428 (1)

Same Patch Batch · fastify · 2026-09-04 · 4 CVEs total

CVE-2026-84504 8.1 HIGH fastify vulnerable to request body replacement via an async validation result collision
CVE-2026-76169 7.5 HIGH fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-f
CVE-2026-84469 7.5 HIGH fastify vulnerable to request validation bypass via skipped boolean false schemas

IV. Related Vulnerabilities