目标达成 感谢每一位支持者 — 我们达成了 100% 目标!

目标: 1000 元 · 已筹: 1359 元

100%

CVE-2026-115930— MongoDB Shell 证书信任漏洞

一分钟漏洞结论

影响对象
MongoDB, Inc. mongosh
利用判断
尚无明确在野利用证据,仍需结合暴露面评估
建议动作
优先检查厂商安全公告和参考链接中的修复版本;无法立即升级时,限制受影响服务暴露并加强监测。

MongoDB Shell(mongosh)依赖 Node.js 作为第三方运行时,该运行时自带其自身的 TLS 根证书存储库。此证书存储库中包含了可恢复的 eMudhra 中间 CA 证书。此问题影响 2.14.0 之前的所有 mongosh 版本,可通过升级至 mongosh 2.14.0(该版本捆绑了 Node.js 24.22.1 或更高版本)来解决。如果 mongosh 是通过 npm 安装的,则它会使用主机上已安装的 Node.js 运行时;此时需单独升级该运行时。

CVSS 6.8 · Medium
获取后续新漏洞提醒 登录后订阅

一、 漏洞 CVE-2026-115930 基础信息

漏洞信息

对漏洞内容有疑问?看看神龙的深度分析是否有帮助!
查看神龙十问 ↗

尽管我们使用了先进的大模型技术,但其输出仍可能包含不准确或过时的信息。神龙努力确保数据的准确性,但请您根据实际情况进行核实和判断。

Vulnerability Title
MongoDB Shell (mongosh) bundled with Node.js trusts certificates issued by recoverable eMudhra intermediate CAs
来源: CVE Program / CVE List V5
Vulnerability Description
The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.
来源: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
来源: CVE Program / CVE List V5
Vulnerability Type
证书验证不恰当
来源: CVE Program / CVE List V5

受影响产品

厂商 产品 影响版本 CPE 订阅
MongoDB, Inc. mongosh 0 ~ 2.14.0 -

二、漏洞 CVE-2026-115930 的公开POC

# POC 描述 源链接 神龙链接
AI 生成 POC 高级

未找到公开 POC。

登录以生成 AI POC

三、漏洞 CVE-2026-115930 的情报信息

请登录查看更多情报信息。

CVE-2026-115930 其他参考 (1)

IV. Related Vulnerabilities