Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2026-44166— Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade

Quick assessment

Affected
pocketbase pocketbase
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

PocketBase是PocketBase开源的一个开源实时后端。 Pocketbase 0.22.42之前版本和0.37.4之前版本存在授权问题漏洞,该漏洞源于在某些情况下,攻击者若知道受害者电子邮件地址,可预先创建并链接未验证的PocketBase用户,导致受害者注册时自动链接并升级为已验证用户。

AI Predicted 8.1 Difficulty: Moderate EPSS 0.25% · P16

Affected Version Matrix 2

VendorProduct Version RangeStatus
pocketbase pocketbase < 0.22.42 affected
>= 0.30.0, < 0.37.4 affected
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2026-44166

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade
Source: CVE Program / CVE List V5
Vulnerability Description
Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N
Source: CVE Program / CVE List V5
Vulnerability Type
认证机制不恰当
Source: CVE Program / CVE List V5
Vulnerability Title
PocketBase 授权问题漏洞
Source: CNNVD (China National Vulnerability Database)
Vulnerability Description
PocketBase是PocketBase开源的一个开源实时后端。 Pocketbase 0.22.42之前版本和0.37.4之前版本存在授权问题漏洞,该漏洞源于在某些情况下,攻击者若知道受害者电子邮件地址,可预先创建并链接未验证的PocketBase用户,导致受害者注册时自动链接并升级为已验证用户。
Source: CNNVD (China National Vulnerability Database)
CVSS Information
N/A
Source: CNNVD (China National Vulnerability Database)
Vulnerability Type
N/A
Source: CNNVD (China National Vulnerability Database)

Affected Products

Vendor Product Affected Versions CPE Subscribe
pocketbase pocketbase < 0.22.42 -

II. Public POCs for CVE-2026-44166

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2026-44166

请登录查看更多情报信息。

Vendor Advisories for CVE-2026-44166 (1)

IV. Related Vulnerabilities