Goal Reached Thanks to every supporter — we hit 100%!

Goal: 1000 CNY · Raised: 1359 CNY

100%

CVE-2026-115917— vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server

Quick assessment

Affected
vllm-project vllm
Exploitation
No confirmed in-the-wild exploitation; assess based on exposure
Recommended action
Check the vendor advisory and references for a fixed version. If immediate upgrade is impossible, restrict exposure and increase monitoring.

vLLM 是一个用于大型语言模型的推理与服务引擎。在 0.32.0 版本之前,其兼容 OpenAI 的服务器默认将 Starlette 的 CORSMiddleware 配置为允许所有来源(即 allowed_origins 设置为通配符)。攻击者可利用恶意网页,通过受害者的浏览器访问位于本地主机、内网或 VPN 中的未认证 vLLM 服务器,调用包括 GET /v1/models 和 POST /v1/chat/completions 在内的接口,从而消耗 GPU 资源并读取响应内容。由于默认禁用了凭据,基于 C

CVSS 3.4 · Low
Get alerts for future matching vulnerabilities Log in to subscribe

I. Basic Information for CVE-2026-115917

Vulnerability Information

Have questions about the vulnerability? See if Shenlong's analysis helps!
View Shenlong Deep Dive ↗

Although we use advanced large model technology, its output may still contain inaccurate or outdated information.Shenlong tries to ensure data accuracy, but please verify and judge based on the actual situation.

Vulnerability Title
vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
Source: CVE Program / CVE List V5
Vulnerability Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
Source: CVE Program / CVE List V5
CVSS Information
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
Source: CVE Program / CVE List V5
Vulnerability Type
过度许可的跨域白名单
Source: CVE Program / CVE List V5

Affected Products

Vendor Product Affected Versions CPE Subscribe
vllm-project vllm < 0.32.0 -

II. Public POCs for CVE-2026-115917

# POC Description Source Link Shenlong Link
AI-Generated POC Premium

No public POC found.

Login to generate AI POC

III. Intelligence Information for CVE-2026-115917

请登录查看更多情报信息。

Patches & Fixes for CVE-2026-115917 (2)

Vendor Advisories for CVE-2026-115917 (1)

Vendor Pages for CVE-2026-115917 (1)

Same Patch Batch · vllm-project · 2026-10-26 · 8 CVEs total

CVE-2026-115915 8.1 HIGH vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
CVE-2026-115912 7.5 HIGH vLLM: Public multimodal SHM handle forgery reaches worker-side `pickle.loads()` with insec
CVE-2026-115911 6.5 MEDIUM vLLM: DoS via unbounded chat_template Jinja2 rendering exhausts the renderer thread pool
CVE-2026-115913 6.5 MEDIUM vLLM: Phi-4 multimodal audio encoder materializes and retains full attention matrices: a s
CVE-2026-115916 6.5 MEDIUM vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device
CVE-2026-115914 6.5 MEDIUM vLLM DeepSeek-OCR image processing vulnerable to denial of service
CVE-2026-115918 6.5 MEDIUM vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs

IV. Related Vulnerabilities